package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^\]]+\]|\{[^\}]+\}|\S+`)
var str = `foo bar["s 1"]{a:{b:["s 2", "s 3"]}, x:" [s 4] "} woo{c:y} [e:{" s [6]"}] {working with unnested curly braces} [working with unnested square brackets]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}