// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[[^\]]+\]|\{[^\}]+\}|\S+").unwrap();
let string = "foo bar[\"s 1\"]{a:{b:[\"s 2\", \"s 3\"]}, x:\" [s 4] \"} woo{c:y} [e:{\" s [6]\"}] {working with unnested curly braces} [working with unnested square brackets]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}