$re = '/\[[^\]]+\]|\{[^\}]+\}|\S+/';
$str = 'foo bar["s 1"]{a:{b:["s 2", "s 3"]}, x:" [s 4] "} woo{c:y} [e:{" s [6]"}] {working with unnested curly braces} [working with unnested square brackets]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);