const regex = /\d(?=(\d{3})+\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?=(\\d{3})+\\.)', 'gm')
const str = `1245332.00`;
const subst = `$&,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);