import Foundation
let pattern = #"\d(?=(\d{3})+\.)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1245332.00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$&,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)