$re = '/\d(?=(\d{3})+\.)/m';
$str = '1245332.00';
$subst = "$&,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;