using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=\w{8}\b)\w*e\w*";
string input = @"abcdefgh ijkemnop mnbvcxze
abcdefgh
ijkemnop
mnbvcxze
mnbvcxzee mnbvcxzet mnbvcxzs
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}