re = /\b(?=\w{8}\b)\w*e\w*/m
str = 'abcdefgh ijkemnop mnbvcxze
abcdefgh
ijkemnop
mnbvcxze
mnbvcxzee mnbvcxzet mnbvcxzs
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end