$re = '/\b(?=\w{8}\b)\w*e\w*/m';
$str = 'abcdefgh ijkemnop mnbvcxze
abcdefgh
ijkemnop
mnbvcxze
mnbvcxzee mnbvcxzet mnbvcxzs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);