package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+[dmy]\b`)
var str = `1d
30m
1232y
e.g. Invalid
1dd
30mm
1232yyy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}