const regex = /\b\d+[dmy]\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+[dmy]\\b', 'gm')
const str = `1d
30m
1232y
e.g. Invalid
1dd
30mm
1232yyy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}