$re = '/\b\d+[dmy]\b/m';
$str = '1d
30m
1232y
e.g. Invalid
1dd
30mm
1232yyy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);