package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w{1,3}([a-zA-Z])(?:\d{1,2}|\d{4})$`)
var str = `QZAB19
AP18
ARM8
ARM803`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}