// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w{1,3}([a-zA-Z])(?:\d{1,2}|\d{4})$").unwrap();
let string = "QZAB19
AP18
ARM8
ARM803";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}