$re = '/^\w{1,3}([a-zA-Z])(?:\d{1,2}|\d{4})$/m';
$str = 'QZAB19
AP18
ARM8
ARM803';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);