$re = '/((?<=^)|(?<=\.))\s*(?![^.]*Bull).*?((?=$)|(?=\.))/m';
$str = 'This is a Dog. This is Cat. This is a Bull. This is a Cow';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);