re = /((?<=^)|(?<=\.))\s*(?![^.]*Bull).*?((?=$)|(?=\.))/m
str = 'This is a Dog. This is Cat. This is a Bull. This is a Cow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end