$re = '/\b(x(?1)y|(?<=x)(?=y))\b/m';
$str = 'xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);