$re = '/^\[[^]]+\].+/m';
$str = '[FIX] [SDK-974] validate head commit format
Commit 2
Commit 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);