$re = '/.*(\[.*?\]).*|.*/';
$str = '## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;