// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(\[.*?\]).*|.*").unwrap();
let string = "## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}