re = /.*(\[.*?\]).*|.*/
str = '## [0.3.0] - 2016-12-13
- FIX This is an example fix
- FEATURE An example feature
## [0.2.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature
## [0.1.0] - 2015-1-3
- FIX This is an example fix
- FEATURE An example feature'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result