package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\s]+_(NNS|CC|VBN)`)
var str = `His_PRP$ plays_NNS remain_VBP highly_RB ?_CC and_CC are_VBP constantly_RB studied._VBN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}