re = /[^\s]+_(NNS|CC|VBN)/
str = 'His_PRP$ plays_NNS remain_VBP highly_RB ?_CC and_CC are_VBP constantly_RB studied._VBN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end