$re = '/[^\s]+_(NNS|CC|VBN)/';
$str = 'His_PRP$ plays_NNS remain_VBP highly_RB ?_CC and_CC are_VBP constantly_RB studied._VBN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);