package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)CA\s19-9\s(\d+)`)
var str = `CA 19-9 25 U/mL 0 - 35 01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}