$re = '/CA\s19-9\s(\d+)/m';
$str = 'CA 19-9 25 U/mL 0 - 35 01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);