package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((-[\w]) (.*)?) ((-[\w]) (.*)?)`)
var str = `-p -s xml -o /path/result.log 'text for search' ./`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}