re = /((-[\w]) (.*)?) ((-[\w]) (.*)?)/
str = '-p -s xml -o /path/result.log \'text for search\' ./'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end