$re = '/((-[\w]) (.*)?) ((-[\w]) (.*)?)/';
$str = '-p -s xml -o /path/result.log \'text for search\' ./';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);