import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*\\[.*\\].*)$|((^(.*(убит|отошел).*)$))";
final String string = "Shoorik отошел\n"
+ "[G] Shoorik я отошел\n"
+ "текст должен выделяться\n"
+ "он был убит а\n"
+ "был убит 123\n"
+ "был убит\n"
+ "и этот текст тоже\n"
+ "[L] был убит\n"
+ "[G] просто текст \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}