const regex = /^(.*\[.*\].*)$|((^(.*(убит|отошел).*)$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\[.*\\].*)$|((^(.*(убит|отошел).*)$))', 'gm')
const str = `Shoorik отошел
[G] Shoorik я отошел
текст должен выделяться
он был убит а
был убит 123
был убит
и этот текст тоже
[L] был убит
[G] просто текст
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}