// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*\[.*\].*)$|((^(.*(убит|отошел).*)$))").unwrap();
let string = "Shoorik отошел
[G] Shoorik я отошел
текст должен выделяться
он был убит а
был убит 123
был убит
и этот текст тоже
[L] был убит
[G] просто текст
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}