const regex = /^[ -~\n\r\t’“”]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ -~\\n\\r\\t’“”]*$', 'gm')
const str = `checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
471
819
855
875
947
1079
1263
1634
checked
checked
checked
checked
2585
2615
checked
checked
2710
2740
checked
checked
3078
3207
3297
3327
checked
checked
3357
3462
3492
3552
3642
3885`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}