re = /^[ -~\n\r\tâââ]*$/m
str = 'checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
471
819
855
875
947
1079
1263
1634
checked
checked
checked
checked
2585
2615
checked
checked
2710
2740
checked
checked
3078
3207
3297
3327
checked
checked
3357
3462
3492
3552
3642
3885'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end