package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<key>\w+) = (?P<value>[^,\n\r]+)`)
var str = `Data:
Version: 3 (0x2)
Serial Number : -283916479 (-0x10ec38bf)
Signature Algorithm : sha256WithRSAEncryption
Issuer : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com
Validity
Not Before : Mar 29 15 : 17 : 00 2017 GMT
Not After : Mar 29 15 : 17 : 00 2022 GMT
Subject : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com
Subject Public Key Info :
Public Key Algorithm : rsaEncryption
Public - Key : (2048 bit)
Modulus :
Exponent : 65537 (0x10001)
Signature Algorithm : sha256WithRSAEncryption
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}