# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<key>\w+) = (?P<value>[^,\n\r]+)"
test_str = ("Data:\n"
"Version: 3 (0x2)\n"
" Serial Number : -283916479 (-0x10ec38bf)\n"
" Signature Algorithm : sha256WithRSAEncryption\n"
" Issuer : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com\n"
" Validity\n"
" Not Before : Mar 29 15 : 17 : 00 2017 GMT\n"
" Not After : Mar 29 15 : 17 : 00 2022 GMT\n"
" Subject : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com\n"
" Subject Public Key Info :\n"
" Public Key Algorithm : rsaEncryption\n"
" Public - Key : (2048 bit)\n"
" Modulus :\n"
" Exponent : 65537 (0x10001)\n"
" Signature Algorithm : sha256WithRSAEncryption\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.