use strict;
my $str = 'Data:
Version: 3 (0x2)
Serial Number : -283916479 (-0x10ec38bf)
Signature Algorithm : sha256WithRSAEncryption
Issuer : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com
Validity
Not Before : Mar 29 15 : 17 : 00 2017 GMT
Not After : Mar 29 15 : 17 : 00 2022 GMT
Subject : C = US, ST = CA, L = San Jose, O = Ubiquiti Networks Inc., OU = Technical Support, CN = UBNT - 80 : 2A : A8 : EE : B0 : A3 / emailAddress = support@ubnt.com
Subject Public Key Info :
Public Key Algorithm : rsaEncryption
Public - Key : (2048 bit)
Modulus :
Exponent : 65537 (0x10001)
Signature Algorithm : sha256WithRSAEncryption
';
my $regex = qr~(?P<key>\w+) = (?P<value>[^,\n\r]+)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}