#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^/\*.*\n.*Copyright.*\n[\s\S]*?\n \*/\n"
Local $sString = "/*" & @CRLF & _
" Copyright © 2019 Apple Inc. All rights reserved." & @CRLF & _
" a sdf ja;sdfj" & @CRLF & _
" asdfijase" & @CRLF & _
" */" & @CRLF & _
"/*" & @CRLF & _
" <samplecode>" & @CRLF & _
" <abstract>" & @CRLF & _
" PositionPlayerTests" & @CRLF & _
" </abstract>" & @CRLF & _
" </samplecode>" & @CRLF & _
" */" & @CRLF & _
"this" & @CRLF & _
"this\" & @CRLF & _
"asdas" & @CRLF & _
"/*" & @CRLF & _
" Copyright © 2020 Apple Inc. All rights reserved." & @CRLF & _
" See Source/LICENSE/LICENSE.txt for details" & @CRLF & _
" */" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"ase" & @CRLF & _
"asdsf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")