re = /^\/\*.*\n.*Copyright.*\n[\s\S]*?\n \*\/\n/
str = '/*
Copyright © 2019 Apple Inc. All rights reserved.
a sdf ja;sdfj
asdfijase
*/
/*
<samplecode>
<abstract>
PositionPlayerTests
</abstract>
</samplecode>
*/
this
this\\
asdas
/*
Copyright © 2020 Apple Inc. All rights reserved.
See Source/LICENSE/LICENSE.txt for details
*/
asdf
asdf
ase
asdsf
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end