# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^/\*.*\n.*Copyright.*\n[\s\S]*?\n \*/\n"
test_str = ("/*\n"
" Copyright © 2019 Apple Inc. All rights reserved.\n"
" a sdf ja;sdfj\n"
" asdfijase\n"
" */\n"
"/*\n"
" <samplecode>\n"
" <abstract>\n"
" PositionPlayerTests\n"
" </abstract>\n"
" </samplecode>\n"
" */\n"
"this\n"
"this\\\n"
"asdas\n"
"/*\n"
" Copyright © 2020 Apple Inc. All rights reserved.\n"
" See Source/LICENSE/LICENSE.txt for details\n"
" */\n"
"asdf\n"
"asdf\n"
"ase\n"
"asdsf\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.