const regex = /<td><p[^>]*>(?:(?!<\/?p).)*<\/p><\/td>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td><p[^>]*>(?:(?!<\\\/?p).)*<\\\/p><\\\/td>', 'gm')
const str = `<tr>
<td><p>Что-то 1</p></td>
<td><p>Что-то 2</p></td>
<td><p style="какой-то стиль"><span style="тоже какая-то ерунда">Что-то 3</span></p><p style="что-нибудь">что-то 4</p></td>
<td><p><b>Что-то 5</b> и что-то 6, <p>при этом что-то 7 с ошибкой</p></p><p>что-то 8</p></td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}