$re = '/<td><p[^>]*>(?:(?!<\/?p).)*<\/p><\/td>/m';
$str = '<tr>
<td><p>Что-то 1</p></td>
<td><p>Что-то 2</p></td>
<td><p style="какой-то стиль"><span style="тоже какая-то ерунда">Что-то 3</span></p><p style="что-нибудь">что-то 4</p></td>
<td><p><b>Что-то 5</b> и что-то 6, <p>при этом что-то 7 с ошибкой</p></p><p>что-то 8</p></td>
</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);