use strict;
my $str = '<tr>
<td><p>Что-то 1</p></td>
<td><p>Что-то 2</p></td>
<td><p style="какой-то стиль"><span style="тоже какая-то ерунда">Что-то 3</span></p><p style="что-нибудь">что-то 4</p></td>
<td><p><b>Что-то 5</b> и что-то 6, <p>при этом что-то 7 с ошибкой</p></p><p>что-то 8</p></td>
</tr>';
my $regex = qr/<td><p[^>]*>(?:(?!<\/?p).)*<\/p><\/td>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}