using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:(?!]).)*?bar";
string input = @"foo bar monkey [foo bar monkey] foo bar monkey, how would you match only the bar
[foo something without boar]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}