$re = '/\[(?:(?!]).)*?bar/';
$str = 'foo bar monkey [foo bar monkey] foo bar monkey, how would you match only the bar
[foo something without boar]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);