re = /\[(?:(?!]).)*?bar/
str = 'foo bar monkey [foo bar monkey] foo bar monkey, how would you match only the bar
[foo something without boar]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end