#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?P<starts_at>\d\d\:\d\d)\s\-\s(?P<ends_at>\d\d\:\d\d)(?P<module_name>[^ ]*)\s\-\s(?P<module_type>[^ ]*)\s(?P<first_name>[^ ]*)\s(?P<last_name>[^ ]*)\s([^ ]*)\s(?P<room>[A-Z]{2,3}\d\d)(?P<weeks>\d-\d{1,2}))\s?"
Local $sString = "10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12 10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")