using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?P<starts_at>\d\d\:\d\d)\s\-\s(?P<ends_at>\d\d\:\d\d)(?P<module_name>[^ ]*)\s\-\s(?P<module_type>[^ ]*)\s(?P<first_name>[^ ]*)\s(?P<last_name>[^ ]*)\s([^ ]*)\s(?P<room>[A-Z]{2,3}\d\d)(?P<weeks>\d-\d{1,2}))\s?";
string input = @"10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12 10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}