$re = '/((?P<starts_at>\d\d\:\d\d)\s\-\s(?P<ends_at>\d\d\:\d\d)(?P<module_name>[^ ]*)\s\-\s(?P<module_type>[^ ]*)\s(?P<first_name>[^ ]*)\s(?P<last_name>[^ ]*)\s([^ ]*)\s(?P<room>[A-Z]{2,3}\d\d)(?P<weeks>\d-\d{1,2}))\s?/m';
$str = '10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12 10:00 - 11:00MK4603 - LEC firstname lastname DR KBG121-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);